aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f72aea..73f7761 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,16 @@ AM_CFLAGS = $(WARN_CFLAGS)
sbin_PROGRAMS = gcrond
-gcrond_SOURCES = gcrond.c gcrond.h rdcron.c crontab.c cronscan.c rdline.c
+gcrond_SOURCES = gcrond.c gcrond.h rdcron.c crontab.c cronscan.c
+gcrond_CPPFLAGS = $(AM_CPPFLAGS)
+gcrond_CFLAGS = $(AM_CFLAGS)
+gcrond_LDADD =
+
+if HAVE_LIBBSD
+gcrond_CPPFLAGS += -DHAVE_LIBBSD
+gcrond_CFLAGS += $(LIBBSD_CFLAGS)
+gcrond_LDADD += $(LIBBSD_LIBS)
+endif
crontabdir = @GCRONDIR@
crontab_DATA = crontab/0-example