aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Oberhollenzer <goliath@infraroot.at>2019-04-03 23:41:09 +0200
committerDavid Oberhollenzer <goliath@infraroot.at>2019-04-04 13:35:44 +0200
commit10b4195af24561c8d4a39b27c31cde21eb1cf1b9 (patch)
tree6b9ea9f7fcfe00c17f89b0ebf9751a708d27cac6 /Makefile.am
parenta02ef642bd6cf6d2584d6f25b379a363e37eb374 (diff)
Replace rdline with libbsd fparselnHEADmaster
Signed-off-by: David Oberhollenzer <goliath@infraroot.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f72aea..73f7761 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,16 @@ AM_CFLAGS = $(WARN_CFLAGS)
sbin_PROGRAMS = gcrond
-gcrond_SOURCES = gcrond.c gcrond.h rdcron.c crontab.c cronscan.c rdline.c
+gcrond_SOURCES = gcrond.c gcrond.h rdcron.c crontab.c cronscan.c
+gcrond_CPPFLAGS = $(AM_CPPFLAGS)
+gcrond_CFLAGS = $(AM_CFLAGS)
+gcrond_LDADD =
+
+if HAVE_LIBBSD
+gcrond_CPPFLAGS += -DHAVE_LIBBSD
+gcrond_CFLAGS += $(LIBBSD_CFLAGS)
+gcrond_LDADD += $(LIBBSD_LIBS)
+endif
crontabdir = @GCRONDIR@
crontab_DATA = crontab/0-example