aboutsummaryrefslogtreecommitdiff
path: root/packages/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'packages/README.md')
-rw-r--r--packages/README.md6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/README.md b/packages/README.md
index 272ea46..09bebf5 100644
--- a/packages/README.md
+++ b/packages/README.md
@@ -35,14 +35,18 @@ Package building for Debian like distibutions is a bit tricky. In this
case we want to add the codename to the version number in order to
differentiate builds.
+To build package for version 1.0.2, run following commands:
+
```
-apt-get install devscripts build-essential libdistro-info-perl
+apt-get install devscripts build-essential wget
source /etc/os-release
wget https://github.com/AgentD/squashfs-tools-ng/archive/v1.0.2/squashfs-tools-ng-1.0.2.tar.gz -O squashfs-tools-ng_1.0.2+$VERSION_CODENAME.orig.tar.gz
tar xfz squashfs-tools-ng_1.0.2+$VERSION_CODENAME.orig.tar.gz
cd squashfs-tools-ng-1.0.2
ln -s packages/debian
DEBFULLNAME="$USER" DEBEMAIL="$USER@localhost" dch -v 1.0.2+$VERSION_CODENAME-1 -D $VERSION_CODENAME "Build 1.0.2 for $VERSION_CODENAME."
+mk-build-deps --install --tool='apt-get --no-install-recommends --yes' debian/control
+rm *.deb
debuild
debuild -- clean
```