aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 04594c8..e885348 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,6 +87,13 @@ AC_ARG_WITH([tools],
[Only build libsquashfs, do not build the tools.])],
[], [with_tools="yes"])
+AC_ARG_ENABLE([copora-tests],
+ [AS_HELP_STRING([--enable-copora-tests],
+ [Perform coprora based reproducability tests.])],
+ [], [enable_copora_tests="no"])
+
+AM_CONDITIONAL([CORPORA_TESTS], [test "x$enable_copora_tests" = "xyes"])
+
AS_IF([test "x$build_windows" = "xyes"], [with_pthread="no"], [])
AS_IF([test "x$with_tools" != "xyes"], [with_selinux="no"], [])
AM_CONDITIONAL([BUILD_TOOLS], [test "x$with_tools" = "xyes"])