aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-12-27 20:50:23 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-12-27 21:19:23 +0100
commit2e109625bb7496bf1f3e75e30345c8cbd6eacede (patch)
tree5500dc821c6a5375d3331c9af8c66f36199b9f94 /configure.ac
parenta69eae98b73856534c43c13c621dfe2822ab0ce6 (diff)
Require the copora tests suits to be enabled explicitly
Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 04594c8..e885348 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,6 +87,13 @@ AC_ARG_WITH([tools],
[Only build libsquashfs, do not build the tools.])],
[], [with_tools="yes"])
+AC_ARG_ENABLE([copora-tests],
+ [AS_HELP_STRING([--enable-copora-tests],
+ [Perform coprora based reproducability tests.])],
+ [], [enable_copora_tests="no"])
+
+AM_CONDITIONAL([CORPORA_TESTS], [test "x$enable_copora_tests" = "xyes"])
+
AS_IF([test "x$build_windows" = "xyes"], [with_pthread="no"], [])
AS_IF([test "x$with_tools" != "xyes"], [with_selinux="no"], [])
AM_CONDITIONAL([BUILD_TOOLS], [test "x$with_tools" = "xyes"])