aboutsummaryrefslogtreecommitdiff
path: root/packages/README.md
diff options
context:
space:
mode:
authorSébastien Gross <seb•ɑƬ•chezwam•ɖɵʈ•org>2020-10-26 19:42:20 +0100
committerDavid Oberhollenzer <goliath@infraroot.at>2020-10-27 11:49:57 +0100
commit93d5f138025b09a4b1093001f33b9dc4c807603d (patch)
tree7f90a91f229a7ec254a9a8333f6b2bd5790983c6 /packages/README.md
parent51c0c5694f6d8c752663f0a515f3b9e1cf081c66 (diff)
Build package using Docker images
Docker image can now be used to build packages for following distributions: * alpine * archlinux * centos * fedora * debian * ubuntu * opensuse Signed-off-by: Sébastien Gross <seb•ɑƬ•chezwam•ɖɵʈ•org>
Diffstat (limited to 'packages/README.md')
-rw-r--r--packages/README.md28
1 files changed, 22 insertions, 6 deletions
diff --git a/packages/README.md b/packages/README.md
index 09bebf5..0e094e0 100644
--- a/packages/README.md
+++ b/packages/README.md
@@ -3,7 +3,23 @@
This directory contains files to build packages for several Linux
distributions.
-# APK
+## Build using Docker images
+
+Packages for a specific release can be built using Docker. Use the
+`build` script for that:
+
+```
+./build VENDOR RELEASE
+```
+
+If you want to build all supported vendors and releases, you can use
+the `build_all` script.
+
+Packages will be output in `_out` directory.
+
+## Manual build
+
+### APK
[APKBUILD]() containts all definition to build APK packages for Alpine
linux.
@@ -26,7 +42,7 @@ abuild-keygen -nai
abuild -r
```
-# DEB
+### DEB
The [debian]() directory contains all definitions to build Debian and
Ubuntu packages.
@@ -52,7 +68,7 @@ debuild -- clean
```
-# PKG
+### PKG
[PKGBUILD]() contains all definition to build Archlinux packages.
@@ -69,12 +85,12 @@ You can check the packages using `namcap`:
namcap -i squashfs-tools-*.pkg.tar.zst PKGBUILD
```
-# RPM
+### RPM
[squashfs-tools-ng.spec]() contains all definitions to build RPM
packages.
-## CentOS, Fedora
+#### CentOS, Fedora
Run following commands:
@@ -86,7 +102,7 @@ rpmspec --parse squashfs-tools-ng.spec | grep BuildRequires | cut -d' ' -f2 | x
rpmbuild --clean -ba squashfs-tools-ng.spec
```
-## OpenSUSE
+### OpenSUSE
Run following commands: