aboutsummaryrefslogtreecommitdiff
path: root/packages/README.md
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2021-01-23 08:48:39 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2021-01-23 09:01:58 +0100
commit574e89b968b671662c78bf5ae4a6dec9d4cdf3ff (patch)
treef447954ec10ce2b72f2b382c734208674a344efc /packages/README.md
parent8026849fda277f54a2a3e4fa5cf5d183cbc84bef (diff)
Bump version numbers & changelog after 1.0.4 release
This commit imports the changes to the CHANGELOG.md in the backports branch after the 1.0.4 release and updates the package scripts to point to the new release. In addition, the version numbers in configure.ac are update to more closeley reflect reality, i.e. set the current so version and set the package version to 1.1.0 which will be the next release from master. The unreleased changes in master are also added to the CHANGELOG.md. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'packages/README.md')
-rw-r--r--packages/README.md10
1 files changed, 5 insertions, 5 deletions
diff --git a/packages/README.md b/packages/README.md
index 0e094e0..341a63c 100644
--- a/packages/README.md
+++ b/packages/README.md
@@ -51,16 +51,16 @@ Package building for Debian like distibutions is a bit tricky. In this
case we want to add the codename to the version number in order to
differentiate builds.
-To build package for version 1.0.2, run following commands:
+To build package for version 1.0.4, run following commands:
```
apt-get install devscripts build-essential wget
source /etc/os-release
-wget https://github.com/AgentD/squashfs-tools-ng/archive/v1.0.2/squashfs-tools-ng-1.0.2.tar.gz -O squashfs-tools-ng_1.0.2+$VERSION_CODENAME.orig.tar.gz
-tar xfz squashfs-tools-ng_1.0.2+$VERSION_CODENAME.orig.tar.gz
-cd squashfs-tools-ng-1.0.2
+wget https://github.com/AgentD/squashfs-tools-ng/archive/v1.0.4/squashfs-tools-ng-1.0.4.tar.gz -O squashfs-tools-ng_1.0.4+$VERSION_CODENAME.orig.tar.gz
+tar xfz squashfs-tools-ng_1.0.4+$VERSION_CODENAME.orig.tar.gz
+cd squashfs-tools-ng-1.0.4
ln -s packages/debian
-DEBFULLNAME="$USER" DEBEMAIL="$USER@localhost" dch -v 1.0.2+$VERSION_CODENAME-1 -D $VERSION_CODENAME "Build 1.0.2 for $VERSION_CODENAME."
+DEBFULLNAME="$USER" DEBEMAIL="$USER@localhost" dch -v 1.0.4+$VERSION_CODENAME-1 -D $VERSION_CODENAME "Build 1.0.4 for $VERSION_CODENAME."
mk-build-deps --install --tool='apt-get --no-install-recommends --yes' debian/control
rm *.deb
debuild