aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-03-18 22:47:15 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-03-18 22:47:15 +0100
commitf3138be38681ab98b947c5e7d4e8fd9392276049 (patch)
tree76dbee8e2e977b949b69303c55ff212bbe7586da /configure.ac
parentddd4f22e33a7d5d9835f129a6cd0af9c175d76a4 (diff)
Set a minimal libzstd version in autoconf script
Version 1.3.1 is the first one which has fixed error codes exposed through the public API, which are used in the zstd compressor to determine whether compression *actually* failed or if the destination buffer was too small. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5cd7ef1..617c9d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,7 +157,7 @@ AS_IF([test "x$with_lz4" != "xno" -a "x$with_builtin_lz4" != "xyes"], [
AS_IF([test "x$with_builtin_lz4" != "xno"], [with_lz4="yes"], [])
AS_IF([test "x$with_zstd" != "xno"], [
- PKG_CHECK_MODULES(ZSTD, [libzstd], [with_zstd="yes"],
+ PKG_CHECK_MODULES(ZSTD, [libzstd >= 1.3.1], [with_zstd="yes"],
[AS_IF([test "x$with_zstd" = "xyes"],
[AC_MSG_ERROR([cannot find zstd])],
[with_zstd="no"])])