aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2022-04-10 19:31:31 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2022-04-10 22:48:34 +0200
commitcb1763e48401d77100630184e56908c287e70109 (patch)
tree1ad820dd12e161a6131841629362bb77b36d65c5 /configure.ac
parent97e4ae237c760144c912530122d3899de850e23f (diff)
Remove builtin copy of zlib
On GNU/Linux, *BSD or MacOS we can simply use the system default library. The copy was primarily only there for the Windows build. The build script for Windows has now been adapted to download and compile a shared library from a tarball. This removes a huge chunk of code from the git tree as well as the release tarballs. Additionally it gets rid of iffy things like removing the Zlib copyright/version strings, so the libsquashfs DLL doesn't export it. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 5c3e426..94a5eee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,10 +110,6 @@ AC_ARG_WITH([gzip],
[AS_HELP_STRING([--with-gzip], [Build with zlib compression support])],
[], [with_gzip="check"])
-AC_ARG_WITH([builtin-zlib],
- [AS_HELP_STRING([--with-builtin-zlib], [Use a custom, static zlib])],
- [], [with_builtin_zlib="no"])
-
AC_ARG_WITH([selinux],
[AS_HELP_STRING([--with-selinux],
[Build with SELinux label file support])],
@@ -184,15 +180,13 @@ AS_IF([test -z "$BZIP2_LIBS"], [AS_IF([test "x$with_bzip2" = "xyes"],
[with_bzip2="no"])],
[with_bzip2="yes"])
-AS_IF([test "x$with_gzip" != "xno" -a "x$with_builtin_zlib" != "xyes"], [
+AS_IF([test "x$with_gzip" != "xno"], [
PKG_CHECK_MODULES(ZLIB, [zlib], [with_gzip="yes"],
[AS_IF([test "x$with_gzip" != "xcheck"],
[AC_MSG_ERROR([cannot find zlib])],
[with_gzip="no"])])
], [])
-AS_IF([test "x$with_builtin_zlib" != "xno"], [with_gzip="yes"], [])
-
AS_IF([test "x$with_xz" != "xno"], [
PKG_CHECK_MODULES(XZ, [liblzma >= 5.0.0], [with_xz="yes"],
[AS_IF([test "x$with_xz" != "xcheck"],
@@ -264,13 +258,12 @@ AM_CONDITIONAL([WITH_SELINUX], [test "x$with_selinux" = "xyes"])
AM_CONDITIONAL([HAVE_PTHREAD], [test "x$with_pthread" = "xyes"])
AM_CONDITIONAL([WITH_OWN_LZ4], [test "x$with_builtin_lz4" = "xyes"])
-AM_CONDITIONAL([WITH_OWN_ZLIB], [test "x$with_builtin_zlib" = "xyes"])
libsqfs_dep_mod=""
AS_IF([test "x$with_lz4" = "xyes" -a "x$with_builtin_lz4" != "xyes"],
[libsqfs_dep_mod="$libsqfs_dep_mod liblz4"], [])
-AS_IF([test "x$with_gzip" = "xyes" -a "x$with_builtin_zlib" != "xyes"],
+AS_IF([test "x$with_gzip" = "xyes"],
[libsqfs_dep_mod="$libsqfs_dep_mod zlib"], [])
AM_COND_IF([WITH_XZ], [libsqfs_dep_mod="$libsqfs_dep_mod liblzma >= 5.0.0"], [])