aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-09-17 13:09:06 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-09-17 13:10:25 +0200
commitb52a9567520570bd6c850bcad3a6966f68639ef7 (patch)
treeb63e6515b25020b3abdfdd63731db0d44ac54925 /configure.ac
parentec38f4fa90d65362002a901b2d74be09fc6b128c (diff)
Add a check whether libzstd supports stream compression
Streaming compression was added fairly recently to zstd (and then the API was changed a few times). Rather than rely on libzstd versioning macros, this commit adds an m4 script to test at configure time if the enums/functions we need are available by trying to compile a small sample. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3de1109..70a1dfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -182,6 +182,8 @@ AS_IF([test "x$with_zstd" != "xno"], [
[with_zstd="no"])])
], [])
+AS_IF([test "x$with_zstd" != "xno"], [AC_TEST_ZSTD_STREAM], [])
+
AS_IF([test "x$with_selinux" != "xno"], [
have_selinux="yes"