aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2022-11-27 10:32:13 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2022-11-27 10:32:13 +0100
commita487eec3e3e7c1c5552d17acd0db8cd5dcc59fc7 (patch)
tree783c4c23ec005545c1cc04925f17c980a4608d93 /configure.ac
parent62e598c500b53902e3d97b62d879e6e9c7785d00 (diff)
Continue cleanup of the test cases
- Force all tests into their proper sub directory - Temporarily remove the corpora tests. They have been used for regression tests before releases and are disabled by default, so we should not ship them either. A script should be added for that, downloading what is needed. - The "pack a directory" test is also removed. It was rather hacky and there already is a test case for the fstree_from_dir function, which isn't ideal either. Something should be added to the regression test suite. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 5d3195f..6d10527 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,13 +125,6 @@ AC_ARG_ENABLE([custom-alloc],
[Do not used any custom allocators.])],
[], [enable_custom_alloc="yes"])
-AC_ARG_ENABLE([corpora-tests],
- [AS_HELP_STRING([--enable-corpora-tests],
- [Perform corpora based reproducability tests.])],
- [], [enable_corpora_tests="no"])
-
-AM_CONDITIONAL([CORPORA_TESTS], [test "x$enable_corpora_tests" = "xyes"])
-
AS_IF([test "x$build_windows" = "xyes"], [with_pthread="no"], [])
AS_IF([test "x$with_tools" != "xyes"], [with_selinux="no"], [])
AM_CONDITIONAL([BUILD_TOOLS], [test "x$with_tools" = "xyes"])
@@ -290,10 +283,8 @@ AM_CONDITIONAL([CUSTOM_ALLOC], [test "x$enable_custom_alloc" = "xyes"])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([lib/sqfs/libsquashfs1.pc])
AC_CONFIG_FILES([Doxyfile])
-AC_CONFIG_FILES([tests/cantrbry.sh], [chmod +x tests/cantrbry.sh])
-AC_CONFIG_FILES([tests/test_tar_sqfs.sh], [chmod +x tests/test_tar_sqfs.sh])
-AC_CONFIG_FILES([tests/pack_dir_root.sh], [chmod +x tests/pack_dir_root.sh])
-AC_CONFIG_FILES([tests/tarcompress.sh], [chmod +x tests/tarcompress.sh])
+AC_CONFIG_FILES([tests/tar2sqfs/test_tar_sqfs.sh],
+ [chmod +x tests/tar2sqfs/test_tar_sqfs.sh])
AC_CONFIG_FILES([tests/rdsquashfs/pathtraversal.sh],
[chmod +x tests/rdsquashfs/pathtraversal.sh])