aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2022-11-22 08:17:28 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2022-11-22 08:17:44 +0100
commit47e531197b18a0e9806bf8e3a2e69f203f5efd13 (patch)
treed2cbe1bd24b0427e69287fc9d83de5bd212f4761 /configure.ac
parent26c72e77a466d6ee6291686fede2d9cfc958474c (diff)
Get rid of the built-in copy of LZ4
On Linux or BSD distributions we have a native version installed via package manager. On Windows, we can just build it from source like the other libraries. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 2 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 29e28c9..5d3195f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,10 +97,6 @@ AC_ARG_WITH([lz4],
[AS_HELP_STRING([--with-lz4], [Build with lz4 compression support])],
[], [with_lz4="check"])
-AC_ARG_WITH([builtin-lz4],
- [AS_HELP_STRING([--with-builtin-lz4], [Use a custom, static liblz4])],
- [], [with_builtin_lz4="no"])
-
AC_ARG_WITH([zstd],
[AS_HELP_STRING([--with-zstd], [Build with zstd compression support])],
[], [with_zstd="check"])
@@ -193,15 +189,13 @@ AS_IF([test "x$with_xz" != "xno"], [
[with_xz="no"])])
], [])
-AS_IF([test "x$with_lz4" != "xno" -a "x$with_builtin_lz4" != "xyes"], [
+AS_IF([test "x$with_lz4" != "xno"], [
PKG_CHECK_MODULES(LZ4, [liblz4], [with_lz4="yes"],
[AS_IF([test "x$with_lz4" = "xyes"],
[AC_MSG_ERROR([cannot find liblz4])],
[with_lz4="no"])])
], [])
-AS_IF([test "x$with_builtin_lz4" != "xno"], [with_lz4="yes"], [])
-
AS_IF([test "x$with_zstd" != "xno"], [
PKG_CHECK_MODULES(ZSTD, [libzstd >= 1.3.1], [with_zstd="yes"],
[AS_IF([test "x$with_zstd" = "xyes"],
@@ -256,10 +250,8 @@ AM_CONDITIONAL([WITH_LZO], [test "x$with_lzo" = "xyes"])
AM_CONDITIONAL([WITH_SELINUX], [test "x$with_selinux" = "xyes"])
AM_CONDITIONAL([HAVE_PTHREAD], [test "x$with_pthread" = "xyes"])
-AM_CONDITIONAL([WITH_OWN_LZ4], [test "x$with_builtin_lz4" = "xyes"])
-
libsqfs_dep_mod=""
-AS_IF([test "x$with_lz4" = "xyes" -a "x$with_builtin_lz4" != "xyes"],
+AS_IF([test "x$with_lz4" = "xyes"],
[libsqfs_dep_mod="$libsqfs_dep_mod liblz4"], [])
AS_IF([test "x$with_gzip" = "xyes"],