aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-09-15 21:13:56 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-09-16 09:34:35 +0200
commit183cf393a453cddb689666ce7fb35a97e7f523bf (patch)
tree7f57b466be7fdbe8cae1ad1f5562fa493ad3312b /configure.ac
parent15431d4fd8de67a03af4ee9cc8e774e1750e9da2 (diff)
Add bzip2 stream compression support
Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3bb300..3de1109 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,11 @@ AM_CONDITIONAL([WINDOWS], [test "x$build_windows" = "xyes"])
##### config options #####
+AC_ARG_WITH([bzip2],
+ [AS_HELP_STRING([--with-bzip2],
+ [Build with bzip2 compression support])],
+ [], [with_bzip2="check"])
+
AC_ARG_WITH([xz],
[AS_HELP_STRING([--with-xz], [Build with xz compression support])],
[], [with_xz="check"])
@@ -138,6 +143,13 @@ fi
##### search for dependencies #####
+AS_IF([test "x$with_bzip2" != "xno"], [
+ PKG_CHECK_MODULES(BZIP2, [bzip2], [with_bzip2="yes"],
+ [AS_IF([test "x$with_bzip2" != "xcheck"],
+ [AC_MSG_ERROR([cannot Bzip2 libs])],
+ [with_bzip2="no"])])
+], [])
+
AS_IF([test "x$with_gzip" != "xno" -a "x$with_builtin_zlib" != "xyes"], [
PKG_CHECK_MODULES(ZLIB, [zlib], [with_gzip="yes"],
[AS_IF([test "x$with_gzip" != "xcheck"],
@@ -206,6 +218,7 @@ AS_IF([test "x$with_pthread" != "xno"], [
[with_pthread="no"])])
], [])
+AM_CONDITIONAL([WITH_BZIP2], [test "x$with_bzip2" = "xyes"])
AM_CONDITIONAL([WITH_GZIP], [test "x$with_gzip" = "xyes"])
AM_CONDITIONAL([WITH_XZ], [test "x$with_xz" = "xyes"])
AM_CONDITIONAL([WITH_LZ4], [test "x$with_lz4" = "xyes"])
@@ -276,6 +289,7 @@ AC_MSG_RESULT([
LZO support: ${with_lzo}
LZ4 support: ${with_lz4}
ZSTD support: ${with_zstd}
+ BZIP2 support: ${with_bzip2}
SELinux support: ${with_selinux}
Using pthreads: ${with_pthread}