aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-04-17 23:52:52 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-04-17 23:52:52 +0200
commit16a22bebb0bb4a28aec9ca76442af93462fc200e (patch)
treef6d84145553686ab0e9be451dcf0e2acb485cd9c /configure.ac
parent1fe3f86230a970b3974f16a6bc2e819fdaf55b58 (diff)
Remove some configure time sizeof checks
In libtar, the sizeof time_t checked when trying to store a time value. It is pointless using the preprocessor here, as we can simply do an if (sizeof(time_t) < ...) check and the compiler will take care optimizing away one or the other branch. After changing the libtar check and the corresponding unit tests, the sizeof check can be removed from configure.ac, along with other unused sizeof checks. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9da88e0..3804631 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,9 +226,7 @@ PKG_CHECK_MODULES(READLINE, [readline], [have_readline="yes"],
AM_CONDITIONAL([WITH_READLINE], [test "x$have_readline" = "xyes"])
##### additional checks #####
-AX_COMPILE_CHECK_SIZEOF(time_t)
AX_COMPILE_CHECK_SIZEOF(size_t)
-AX_COMPILE_CHECK_SIZEOF(short)
AX_COMPILE_CHECK_SIZEOF(int)
AX_COMPILE_CHECK_SIZEOF(long)
AX_COMPILE_CHECK_SIZEOF(long long)