aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-10-08 15:17:59 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-10-08 17:45:28 +0200
commit7c605f573122d346c20d9ac3be6db05959f4eaf8 (patch)
tree888d12e800d9c5bdea8ce0208a1d46e194ed8d11 /Makefile.am
parent7e9d4eeea163658d2ea99d15dfd340bcbe7c1a69 (diff)
Add a configure option to disable building the tools
If this option is used, only libsquashfs is built and installed, and the test cases for the other helper libraries are deactivated. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cbf21b9..e603912 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,16 +15,20 @@ pkgconfig_DATA =
EXTRA_DIST = autogen.sh LICENSE-gpl.txt LICENSE-lgpl.txt README.md CHANGELOG.md
TESTS =
+include lib/sqfs/Makemodule.am
+include lib/util/Makemodule.am
+
+if BUILD_TOOLS
include doc/Makemodule.am
include lib/fstree/Makemodule.am
-include lib/sqfs/Makemodule.am
include lib/common/Makemodule.am
include lib/tar/Makemodule.am
-include lib/util/Makemodule.am
include tar/Makemodule.am
include mkfs/Makemodule.am
include unpack/Makemodule.am
include difftool/Makemodule.am
+endif
+
include tests/Makemodule.am
if HAVE_DOXYGEN