aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@tele2.at>2018-09-01 01:12:46 +0200
committerDavid Oberhollenzer <david.oberhollenzer@tele2.at>2018-09-01 13:03:18 +0200
commitdc30dd7530cee426bbb30425e255868ffa635c13 (patch)
tree5f8c9dce00a58bd82ece93db86c93c783a773c37 /configure.ac
parentb0b6c68e3839656c657f83de70badace6c01675a (diff)
Add tiny klogd implementation
Signed-off-by: David Oberhollenzer <david.oberhollenzer@tele2.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 99e4b2d..01cff9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,15 @@ AC_ARG_WITH([usyslogd],
esac],
[AM_CONDITIONAL([USYSLOGD], [true])])
+AC_ARG_WITH([klogd],
+ [AS_HELP_STRING([--without-klogd], [Build without kernel log daemon])],
+ [case "${withval}" in
+ yes) AM_CONDITIONAL([KLOGD], [true]) ;;
+ no) AM_CONDITIONAL([KLOGD], [false]) ;;
+ *) AC_MSG_ERROR([bad value ${withval} for --without-klogd]) ;;
+ esac],
+ [AM_CONDITIONAL([KLOGD], [true])])
+
AC_CONFIG_HEADERS([lib/include/config.h])
AC_DEFINE_DIR(SVCDIR, sysconfdir/init.d, [Startup service directory])