aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@tele2.at>2018-06-02 16:20:02 +0200
committerDavid Oberhollenzer <david.oberhollenzer@tele2.at>2018-06-11 19:45:42 +0200
commitf52c7ea9d045db3a1f313f92ef786cbb58594a50 (patch)
tree0ce30b8ac515987b87a609eb2403e218bf6ff07d /Makefile.am
parented23d075cae1353dcbec06925b2491e09395aafe (diff)
Add minimalistic syslog daemon
For now this daemon simply dumps all syslog messages into seperate log files and doesn't do much parsing. Since the messages are readable ASCII anyway, this should not be to much of a problem and sufficient for debugging. Signed-off-by: David Oberhollenzer <david.oberhollenzer@tele2.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0b24ded..09fa4ef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,10 @@ include initd/Makemodule.am
include scripts/Makemodule.am
include services/Makemodule.am
+if USYSLOGD
+include syslogd/Makemodule.am
+endif
+
install-data-local:
$(MKDIR_P) $(DESTDIR)$(SVCDIR)
$(LN_S) $(TEMPLATEDIR)/loopback $(DESTDIR)$(SVCDIR)/loopback
@@ -39,3 +43,6 @@ install-data-local:
$(LN_S) $(TEMPLATEDIR)/sigkill $(DESTDIR)$(SVCDIR)/sigkill@reboot
$(LN_S) $(TEMPLATEDIR)/sigterm $(DESTDIR)$(SVCDIR)/sigterm@reboot
$(LN_S) $(TEMPLATEDIR)/ifcfg $(DESTDIR)$(SVCDIR)/ifcfg
+if USYSLOGD
+ $(LN_S) $(TEMPLATEDIR)/usyslogd $(DESTDIR)$(SVCDIR)/usyslogd
+endif