aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@tele2.at>2018-11-05 15:56:27 +0100
committerDavid Oberhollenzer <david.oberhollenzer@tele2.at>2018-11-05 16:01:57 +0100
commita8f3360e938b3cfc8b785222be522cdbf83e5692 (patch)
treec791cadc7fc6bb062173e40218ec9fd2749fe3f8 /Makefile.am
parent5923ad488a1eb3c41e07cf598c1251ce07ea6c04 (diff)
Split default init scripts into seperate package
Signed-off-by: David Oberhollenzer <david.oberhollenzer@tele2.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 4 insertions, 25 deletions
diff --git a/Makefile.am b/Makefile.am
index 19b79e8..f818627 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,14 +6,15 @@ AM_CFLAGS = $(WARN_CFLAGS)
bin_PROGRAMS =
sbin_PROGRAMS =
noinst_LIBRARIES =
-nobase_sysconf_DATA = netcfg/ifrename
+nobase_sysconf_DATA =
sysconf_DATA = etc/initd.env
-EXTRA_DIST = README.md LICENSE docs netcfg
helperdir = @SCRIPTDIR@
helper_PROGRAMS =
helper_SCRIPTS =
+EXTRA_DIST = README.md LICENSE docs
+
dist_man1_MANS =
dist_man8_MANS =
@@ -21,8 +22,6 @@ include lib/Makemodule.am
include cmd/Makemodule.am
include initd/Makemodule.am
include crond/Makemodule.am
-include scripts/Makemodule.am
-include services/Makemodule.am
install-exec-hook:
(cd $(DESTDIR)$(sbindir); $(LN_S) shutdown reboot)
@@ -31,27 +30,7 @@ install-data-local:
$(MKDIR_P) $(DESTDIR)$(man8dir)
(cd $(DESTDIR)$(man8dir); $(LN_S) shutdown.8 reboot.8)
$(MKDIR_P) $(DESTDIR)$(SVCDIR)
- $(LN_S) $(TEMPLATEDIR)/loopback $(DESTDIR)$(SVCDIR)/loopback
- $(LN_S) $(TEMPLATEDIR)/hostname $(DESTDIR)$(SVCDIR)/hostname
- $(LN_S) $(TEMPLATEDIR)/sysctl $(DESTDIR)$(SVCDIR)/sysctl
- $(LN_S) $(TEMPLATEDIR)/sysinit $(DESTDIR)$(SVCDIR)/sysinit
- $(LN_S) $(TEMPLATEDIR)/procfs $(DESTDIR)$(SVCDIR)/procfs
- $(LN_S) $(TEMPLATEDIR)/sysfs $(DESTDIR)$(SVCDIR)/sysfs
- $(LN_S) $(TEMPLATEDIR)/devfs $(DESTDIR)$(SVCDIR)/devfs
- $(LN_S) $(TEMPLATEDIR)/tmpfs $(DESTDIR)$(SVCDIR)/tmpfs
- $(LN_S) $(TEMPLATEDIR)/vfs $(DESTDIR)$(SVCDIR)/vfs
- $(LN_S) $(TEMPLATEDIR)/ifdown $(DESTDIR)$(SVCDIR)/ifdown@shutdown
- $(LN_S) $(TEMPLATEDIR)/sync $(DESTDIR)$(SVCDIR)/sync@shutdown
- $(LN_S) $(TEMPLATEDIR)/sigkill $(DESTDIR)$(SVCDIR)/sigkill@shutdown
- $(LN_S) $(TEMPLATEDIR)/sigterm $(DESTDIR)$(SVCDIR)/sigterm@shutdown
- $(LN_S) $(TEMPLATEDIR)/sync $(DESTDIR)$(SVCDIR)/sync@reboot
- $(LN_S) $(TEMPLATEDIR)/sigkill $(DESTDIR)$(SVCDIR)/sigkill@reboot
- $(LN_S) $(TEMPLATEDIR)/sigterm $(DESTDIR)$(SVCDIR)/sigterm@reboot
- $(LN_S) $(TEMPLATEDIR)/ifdown $(DESTDIR)$(SVCDIR)/ifdown@reboot
- $(LN_S) $(TEMPLATEDIR)/ifcfg $(DESTDIR)$(SVCDIR)/ifcfg
- $(LN_S) $(TEMPLATEDIR)/modules $(DESTDIR)$(SVCDIR)/modules
- $(LN_S) $(TEMPLATEDIR)/network $(DESTDIR)$(SVCDIR)/network
+ $(MKDIR_P) $(DESTDIR)$(TEMPLATEDIR)
if GCROND
$(MKDIR_P) $(DESTDIR)$(GCRONDIR)
- $(LN_S) $(TEMPLATEDIR)/gcrond $(DESTDIR)$(SVCDIR)/gcrond
endif