aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index edd9500..fcd0e67 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,4 +41,13 @@ AC_CONFIG_FILES([scripts/modules_load.sh])
AC_CONFIG_FILES([crontab/swclock])
+AC_ARG_ENABLE([swclock],
+ [AS_HELP_STRING([--enable-swclock], [Enable software pseudo RTC])],
+ [case "${enableval}" in
+ yes) AM_CONDITIONAL([SWCLOCK], [true]) ;;
+ no) AM_CONDITIONAL([SWCLOCK], [false]) ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-swclock]) ;;
+ esac],
+ [AM_CONDITIONAL([SWCLOCK], [false])])
+
AC_OUTPUT([Makefile])