aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2021-02-28 14:22:31 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2024-02-19 09:04:00 +0100
commit7add1c1dbc8781de79fb718165d49d9f549207cd (patch)
tree71ed0385b9afbc0f24c635f657f7a1c41064a7d0 /configure.ac
parentedc83b61745e6ee7fa9c9502eb520493832b1e9c (diff)
Add a build summary to configure.ac
Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2c5c54..f8f2ea2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -292,3 +292,40 @@ AC_CONFIG_FILES([tests/fs-tests/fs_help_all.sh
tests/ubi-tests/ubi-stress-test.sh])
AC_OUTPUT([Makefile])
+
+AC_MSG_RESULT([
+ ${PACKAGE} ${VERSION}
+
+ prefix: ${prefix}
+ exec prefix: ${exec_prefix}
+
+ runstatedir: ${runstatedir}
+ bindir: ${bindir}
+ sbindir: ${sbindir}
+ libdir: ${libdir}
+ includedir: ${includedir}
+
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ ldflags: ${LDFLAGS}
+
+ lzo support: ${with_lzo}
+ zlib support: ${with_zlib}
+ zstd support: ${with_zstd}
+ xattr/acl support: ${with_xattr}
+ SELinux support: ${with_selinux}
+ fscrypt support: ${with_crypto}
+
+ Test programs: ${with_tests}
+ Unit tests: ${enable_unit_tests}
+ ubihealthd: ${enable_ubihealthd}
+ lsmtd: ${with_lsmtd}
+ jffs2 utils: ${with_jffs}
+ ubifs utils: ${with_ubifs}
+
+ warnings:
+
+${WARN_CFLAGS}
+
+ Type 'make' or 'make <utilname>' to compile.
+])