aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJuergen Borleis <jbe@pengutronix.de>2020-11-25 11:25:47 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-11-29 23:28:43 +0100
commit5a6e813a6ba48c81889208bdbeff92b13958dd2d (patch)
tree55f170c32e135a27e5cf5b79e99d1ba605d9545d /configure.ac
parentefeba0875ed181e7c1c7915742a3868799604d0c (diff)
mtd-utils: ubihealthd: this tool does not depend on UBIFS
The "need_getrandom" check and result is used only for the "ubihealthd". This tool is very important to have it around at run-time, while the corresponding "mkfs.ubifs" tool is still optional (think about offline generated ubifs images). Since compiling "mkfs.ubifs" adds more dependencies (various shared libraries), buildsystems for embedded devices will add these shared libraries to the root filesystem even if "mkfs.ubifs" isn't used or installed. Thus, handling both tools independently makes sense. The previous behavior is kept, e.g. if UBIFS support is enabled, it enables "ubihealthd" as well. Signed-off-by: Juergen Borleis <jbe@pengutronix.de> Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bcea080..a5f6261 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,7 +71,6 @@ need_xattr="no"
need_cmocka="no"
need_selinux="no"
need_openssl="no"
-need_getrandom="no"
AM_COND_IF([UNIT_TESTS], [
need_cmocka="yes"
@@ -107,6 +106,9 @@ AM_COND_IF([INSTALL_TESTS],
[AC_SUBST(testbindir, ["\$libexecpath"])],
[AC_SUBST(testbindir, ["\".\""])])
+AC_ARG_ENABLE([ubihealthd],
+ [AS_HELP_STRING([--enable-ubihealthd], [Build the ubihealthd program])],
+ [need_getrandom="${enableval}"],[need_getrandom="auto"])
AC_ARG_ENABLE([lsmtd],
[AS_HELP_STRING([--disable-lsmtd], [Do not build the lsmtd program])],
@@ -142,7 +144,7 @@ AM_COND_IF([BUILD_UBIFS], [
need_lzo="yes"
need_zstd="yes"
need_openssl="yes"
- need_getrandom="yes"
+ AS_VAR_IF([need_getrandom], [auto], [need_getrandom="yes"])
])
AM_COND_IF([BUILD_JFFSX], [