aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2024-02-18 13:52:42 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2024-02-18 13:54:59 +0100
commit3f73bfb3e09c407425245aa5f62477fd572328c9 (patch)
tree7f2b7088c24d7029de19ac253432dca11ad3c458 /Makefile.am
parentab4628e756ab73d8193ed62b591417dad561b298 (diff)
Make it possible to compile jffsX-utils without zlib
The jffsX-utils already have a CONFIG_JFFS2_ZLIB define, but it is statically defined in a header and not used consistently. This patch first replaces it with a "WITH_ZLIB" define, provided via automake, to bring it in line with the already existing "WITH_LZO". Then, the missing checks and typedefs are added in jffs2reader.c. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 299a5fb..06d154a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,8 @@ ACLOCAL_AMFLAGS = -I m4
AM_CPPFLAGS = $(WARN_CFLAGS) -D_GNU_SOURCE -std=gnu99 -I$(top_srcdir)/include \
-include $(top_builddir)/include/config.h
+AM_CPPFLAGS += -DWITH_ZLIB
+
if WITH_XATTR
AM_CPPFLAGS += -DWITH_XATTR
endif