aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2024-02-17 16:37:56 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2024-02-18 14:27:31 +0100
commit2465754716634422620b4577e0b7ba79c4ce1a39 (patch)
tree06c5f642f610e821c21f242247f1dbf18c109319 /Makefile.am
parent2bca2a9dea4c3debc2565b58b3a7f095be2f7b75 (diff)
Make zlib an optional dependency
Now that we have plumbing in place for both jffsX-utils and mkfs.ubifs, add the missing autoconf and automake changes to allow mtd-utils to be built without a hard dependency on zlib. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 06d154a..11647ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,9 @@ ACLOCAL_AMFLAGS = -I m4
AM_CPPFLAGS = $(WARN_CFLAGS) -D_GNU_SOURCE -std=gnu99 -I$(top_srcdir)/include \
-include $(top_builddir)/include/config.h
+if WITH_ZLIB
AM_CPPFLAGS += -DWITH_ZLIB
+endif
if WITH_XATTR
AM_CPPFLAGS += -DWITH_XATTR