summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-10-08 15:17:59 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-10-08 17:45:28 +0200
commit7c605f573122d346c20d9ac3be6db05959f4eaf8 (patch)
tree888d12e800d9c5bdea8ce0208a1d46e194ed8d11 /configure.ac
parent7e9d4eeea163658d2ea99d15dfd340bcbe7c1a69 (diff)
Add a configure option to disable building the tools
If this option is used, only libsquashfs is built and installed, and the test cases for the other helper libraries are deactivated. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 20 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 4eaa61c..018b3f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,13 @@ AC_ARG_WITH([pthread],
[Build without pthread based block compressor])],
[want_pthread="${withval}"], [want_pthread="yes"])
+AC_ARG_WITH([tools],
+ [AS_HELP_STRING([--without-tools],
+ [Only build libsquashfs, do not build the tools.])],
+ [build_tools="${withval}"], [build_tools="yes"])
+
+AM_CONDITIONAL([BUILD_TOOLS], [test "x$build_tools" = "xyes"])
+
##### Doxygen reference manual #####
AC_CHECK_PROGS([DOXYGEN], [doxygen])
@@ -131,17 +138,21 @@ if test "x$want_lzo" != "xno"; then
)
fi
-AM_CONDITIONAL([WITH_SELINUX], [false])
+if test "x$build_tools" = "xyes"; then
+ AM_CONDITIONAL([WITH_SELINUX], [false])
-if test "x$want_selinux" != "xno"; then
- AM_CONDITIONAL([WITH_SELINUX], [true])
+ if test "x$want_selinux" != "xno"; then
+ AM_CONDITIONAL([WITH_SELINUX], [true])
- PKG_CHECK_MODULES(LIBSELINUX, [libselinux], [],
- [AM_CONDITIONAL([WITH_SELINUX], [false])])
- AC_CHECK_HEADERS([selinux/selinux.h], [],
- [AM_CONDITIONAL([WITH_SELINUX], [false])])
- AC_CHECK_HEADERS([selinux/label.h], [],
- [AM_CONDITIONAL([WITH_SELINUX], [false])])
+ PKG_CHECK_MODULES(LIBSELINUX, [libselinux], [],
+ [AM_CONDITIONAL([WITH_SELINUX], [false])])
+ AC_CHECK_HEADERS([selinux/selinux.h], [],
+ [AM_CONDITIONAL([WITH_SELINUX], [false])])
+ AC_CHECK_HEADERS([selinux/label.h], [],
+ [AM_CONDITIONAL([WITH_SELINUX], [false])])
+ fi
+else
+ want_selinux="no"
fi
case "$want_xz" in