summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-11-23 22:42:13 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-11-23 22:42:43 +0100
commit5ab2bc99e0138a6898084cffd4ea41fef3a97ab9 (patch)
treef0bbbb1bc1359c9564dc8c2544734037d7e0ba2d /configure.ac
parent2eaf7d3ef05047dd346dacafb268b9bc67f7ba56 (diff)
Fix: don't search for liblzo if the precious variable is already set
Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3991e53..98259c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,12 +147,14 @@ if test "x$want_lzo" != "xno"; then
AC_ARG_VAR([LZO_LIBS], [linker flags for lzo])
AM_CONDITIONAL([WITH_LZO], [true])
- AC_CHECK_LIB([lzo2], [lzo1x_1_15_compress], [LZO_LIBS="-llzo2"],
- [AC_CHECK_LIB([lzo],[lzo1x_1_15_compress],
- [LZO_LIBS="-llzo"],
- [AM_CONDITIONAL([WITH_LZO], [false])]
- )]
- )
+ if test -z "$LZO_LIBS"; then
+ AC_CHECK_LIB([lzo2], [lzo1x_1_15_compress], [LZO_LIBS="-llzo2"],
+ [AC_CHECK_LIB([lzo],[lzo1x_1_15_compress],
+ [LZO_LIBS="-llzo"],
+ [AM_CONDITIONAL([WITH_LZO], [false])]
+ )]
+ )
+ fi
fi
if test "x$build_tools" = "xyes"; then