summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-09-09 14:47:40 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-09-09 14:48:17 +0200
commit524869a644004b2b5eae9c6cdb14a20c0e877778 (patch)
treeba615cc6a145888016e62f541d20fe2a251fae5c /configure.ac
parent51ffaaee97e6eeaa2117d4349fbbc97bf5721224 (diff)
Add Doxygen based reference manual to build system
This commit modifies the build system to optionally generate a reference manual for libsquashfs using Doxygen (if Doxygen is available and the manual is explicitly built). Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 96c6962..3aa337b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,29 @@ AC_ARG_WITH([pthread],
[Build without pthread based block compressor])],
[want_pthread="${withval}"], [want_pthread="yes"])
+##### Doxygen reference manual #####
+
+AC_CHECK_PROGS([DOXYGEN], [doxygen])
+AM_CONDITIONAL([HAVE_DOXYGEN], [test -n "$DOXYGEN"])
+
+if test -z "$DOXYGEN"; then
+ AC_MSG_WARN([Doxygen not found - continuing without Doxygen support])
+else
+ AC_CONFIG_FILES([Doxyfile])
+
+ DX_DOXYGEN_FEATURE(ON)
+ DX_DOT_FEATURE(ON)
+ DX_HTML_FEATURE(ON)
+ DX_CHM_FEATURE(OFF)
+ DX_CHI_FEATURE(OFF)
+ DX_MAN_FEATURE(OFF)
+ DX_RTF_FEATURE(OFF)
+ DX_XML_FEATURE(OFF)
+ DX_PDF_FEATURE(OFF)
+ DX_PS_FEATURE(OFF)
+ DX_INIT_DOXYGEN(libsquashfs, Doxyfile)
+fi
+
##### search for dependencies #####
AM_CONDITIONAL([WITH_GZIP], [true])