summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-08-14 14:56:21 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-08-18 22:44:39 +0200
commit1a95478b8d340c8b6b9dbff4f38f9293388fd1a3 (patch)
treeb62599b67c54132e1a7bd2559e422e3c5163563b /configure.ac
parent7ca19d23cb4913b5dabfdf3469852ec9f2c0f8d7 (diff)
Add pthread based, parallel block processor implementation
Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 19ee8d4..78ede8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,6 +143,10 @@ yes) AM_COND_IF([WITH_SELINUX], [], [AC_MSG_ERROR([cannot find selinux])]) ;;
no) AM_CONDITIONAL([WITH_SELINUX], [false]) ;;
esac
+have_pthread="no"
+AX_PTHREAD([have_pthread="yes"], [])
+AM_CONDITIONAL([HAVE_PTHREAD], [test "x$have_pthread" != "xno"])
+
##### sanity check #####
have_compressor="no"