summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-05-04 20:47:39 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2019-05-04 22:22:48 +0200
commit7070857b47373dafc1ab93fadec79243da589a1a (patch)
tree760817fb41a74984a499bc88d5ae84d4a0a4ebb8 /configure.ac
parent2b975a449c17268f943403176a7609079b7af084 (diff)
Rename lzma compressor to xz, zlib compressor to gzip
Stick to the terminology that SquashFS uses. SquashFS uses "lzma" to refere to lzma1, "xz" to refere to lzma2 and confusingly "gzip" to refere to raw zlib deflate. We can avoid a lot of confusion by _consistently_ using the same terminology. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 19 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 51c61a4..4cb29bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,41 +41,41 @@ AC_SUBST([WARN_CFLAGS])
##### config options #####
-AC_ARG_WITH([zlib],
- [AS_HELP_STRING([--without-zlib],
- [Build without zlib compression support])],
+AC_ARG_WITH([gzip],
+ [AS_HELP_STRING([--without-gzip],
+ [Build without gzip compression support])],
[case "${withval}" in
- yes) AM_CONDITIONAL([WITH_ZLIB], [true]) ;;
- no) AM_CONDITIONAL([WITH_ZLIB], [false]) ;;
- *) AC_MSG_ERROR([bad value ${withval} for --without-zlib]) ;;
+ yes) AM_CONDITIONAL([WITH_GZIP], [true]) ;;
+ no) AM_CONDITIONAL([WITH_GZIP], [false]) ;;
+ *) AC_MSG_ERROR([bad value ${withval} for --without-gzip]) ;;
esac],
- [AM_CONDITIONAL([WITH_ZLIB], [true])])
+ [AM_CONDITIONAL([WITH_GZIP], [true])])
-AC_ARG_WITH([lzma],
- [AS_HELP_STRING([--without-lzma],
- [Build without lzma compression support])],
+AC_ARG_WITH([xz],
+ [AS_HELP_STRING([--without-xz],
+ [Build without xz compression support])],
[case "${withval}" in
- yes) AM_CONDITIONAL([WITH_LZMA], [true]) ;;
- no) AM_CONDITIONAL([WITH_LZMA], [false]) ;;
- *) AC_MSG_ERROR([bad value ${withval} for --without-lzma]) ;;
+ yes) AM_CONDITIONAL([WITH_XZ], [true]) ;;
+ no) AM_CONDITIONAL([WITH_XZ], [false]) ;;
+ *) AC_MSG_ERROR([bad value ${withval} for --without-xz]) ;;
esac],
- [AM_CONDITIONAL([WITH_LZMA], [true])])
+ [AM_CONDITIONAL([WITH_XZ], [true])])
##### search for dependencies #####
need_zlib="no"
-need_lzma="no"
+need_xz="no"
-AM_COND_IF([WITH_ZLIB], [need_zlib="yes"])
-AM_COND_IF([WITH_LZMA], [need_lzma="yes"])
+AM_COND_IF([WITH_GZIP], [need_zlib="yes"])
+AM_COND_IF([WITH_XZ], [need_xz="yes"])
if test "x$need_zlib" = "xyes"; then
PKG_CHECK_MODULES(ZLIB, [zlib], [], [AC_MSG_ERROR([cannot find zlib])])
fi
-if test "x$need_lzma" = "xyes"; then
+if test "x$need_xz" = "xyes"; then
PKG_CHECK_MODULES(XZ, [liblzma >= 5.0.0], [],
- [AC_MSG_ERROR([cannot find lzma])])
+ [AC_MSG_ERROR([cannot find xz sdk])])
fi
##### generate output #####