summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-09-23 13:45:02 -0700
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2024-09-25 09:08:41 +0200
commitde1386406f5130876be25d9fbee685fb9f0b3020 (patch)
treefd1b4dc6b066a8b8235ed870fb67a38dc0d0bfc6 /configure.ac
parent729e703285f86b1a696df98276bf26058e3a04fa (diff)
mtd-utils: also check for static libuuid
PKG_CHECK_MODULES confusingly does not check to see if a static version of the library is available. Actually with older glibc, it might fail as lpthread needs to be passed to linker flags (Libs.private in pc files) which can only be obtained if --static is passed to pkg-config. Signed-off-by: Rosen Penev <rosenp@gmail.com> Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cf3a959..6222356 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,7 +145,8 @@ AS_IF([test "x$with_zlib" != "xno"], [
], [])
if test "x$need_uuid" = "xyes"; then
- PKG_CHECK_MODULES(UUID, [uuid], [], [uuid_missing="yes"])
+ PKG_CHECK_MODULES(UUID, [uuid], [],
+ [PKG_CHECK_MODULES_STATIC(UUID, [uuid], [], [uuid_missing="yes"])])
fi
if test "x$need_clock_gettime" = "xyes"; then