summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2018-06-18 11:35:59 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2018-06-18 12:22:26 +0200
commit45c59cf18220485f7999ab988c5b10fad385298d (patch)
tree10a102a4c90e96116bcbd393eb2a8b127b75841b /configure.ac
parent4e2d26611d93f522ce399b36f197dc959114b1ee (diff)
Add configure switch to disable compiling/installing lsmtd
Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c05d362..c596eda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,6 +106,16 @@ AM_COND_IF([INSTALL_TESTS],
[AC_SUBST(testbindir, ["\".\""])])
+AC_ARG_ENABLE([lsmtd],
+ [AS_HELP_STRING([--disable-lsmtd], [Do not build the lsmtd program])],
+ [case "${enableval}" in
+ yes) AM_CONDITIONAL([BUILD_LSMTD], [true]) ;;
+ no) AM_CONDITIONAL([BUILD_LSMTD], [false]) ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --disable-lsmtd]) ;;
+ esac],
+ [AM_CONDITIONAL([BUILD_LSMTD], [true])])
+
+
AC_ARG_WITH([jffs],
[AS_HELP_STRING([--without-jffs], [Disable jffsX utilities])],
[case "${withval}" in