aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-10-19 12:14:25 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2021-01-20 12:01:53 +0100
commit7170a28d46d5db1e7a9da24a5555a194a233ef0b (patch)
treead9ef7d83143df6c5597473ef24b6bebbd7a6a63 /configure.ac
parenta888044525d9f03290cc1afe62dcfa3bec4bc0b9 (diff)
Fix test binary installation
- Remove "install tests" configure option, we already have an option whether to build tests or not. Don't try to work around autotools semantics that people building the package expect. - Fix the installation path by propperly defining it and using the correct name for the libexec path. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index a5f6261..a792bd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,20 +91,8 @@ AM_COND_IF([BUILD_TESTS], [
need_pthread="yes"
])
-
-AC_ARG_ENABLE([install-tests],
- [AS_HELP_STRING([--enable-install-tests], [Install test programs])],
- [case "${enableval}" in
- yes) AM_CONDITIONAL([INSTALL_TESTS], [true]) ;;
- no) AM_CONDITIONAL([INSTALL_TESTS], [false]) ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --enable-install-tests]) ;;
- esac],
- [AM_CONDITIONAL([INSTALL_TESTS], [false])])
-
-
-AM_COND_IF([INSTALL_TESTS],
- [AC_SUBST(testbindir, ["\$libexecpath"])],
- [AC_SUBST(testbindir, ["\".\""])])
+AC_DEFINE_DIR(TESTBINDIR, libexecdir/mtd-utils,
+ [Path where test and debug programs will be installed])
AC_ARG_ENABLE([ubihealthd],
[AS_HELP_STRING([--enable-ubihealthd], [Build the ubihealthd program])],