aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2018-05-12 23:28:13 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2018-05-12 23:28:13 +0200
commit64f61a9dc71b158c7084006cbce4ea23886f0b47 (patch)
tree38c9811b422f98acb24dbd30b14132e578b88898 /configure.ac
parent4c00cf2c5816b69754bf7304edcd0e3eb604e3b3 (diff)
mtd-utils: make sure pkg-config is installed in configure script
This patch adds a check to configure.ac that tests if pkg-config is available on the system. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ac45c7..f5538a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,15 @@ AC_DISABLE_STATIC
AC_PROG_CC
AC_PROG_INSTALL
+
+m4_ifndef([PKG_PROG_PKG_CONFIG],
+ [m4_fatal([Could not locate the pkg-config autoconf
+ macros. These are usually located in /usr/share/aclocal/pkg.m4.
+ If your macros are in a different location, try setting the
+ environment variable AL_OPTS="-I/other/macro/dir" before running
+ ./autogen.sh or autoreconf again. Make sure pkg-config is installed.])])
+PKG_PROG_PKG_CONFIG
+
## compiler warnings
UL_WARN_ADD([-Wall])
UL_WARN_ADD([-Wextra])