aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2016-11-29 22:31:11 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2016-11-29 22:31:11 +0100
commit3a6aff82ce1419350514942e7fca1769793bcd7a (patch)
treebbd4e79001d949c10c2768ec2c5d5dfd85bf26ce /configure.ac
parent5a7f6196e6cada162cdb89e56841ececb1a7a3a5 (diff)
Define WITHOUT_XATTR if sys/acl.h or sys/xattr.h is missing
The programs mkfs.jffs2 and mkfs.ubifs include those two headers if WITHOUT_XATTR is not defined. Up to now, this macro is only defined if the configure script is run with --without-xattr. If the headers are not present on a system and the configure script is run without special flags set, the build fails. This patch adds a check for the presence of those headers and disables the feature if one of the headers is missing. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 18ff9af..2fdf49c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,9 @@ AC_ARG_WITH([xattr],
esac],
[AM_CONDITIONAL([WITHOUT_XATTR], [false])])
+AC_CHECK_HEADER(sys/xattr.h, [], [AM_CONDITIONAL([WITHOUT_XATTR], [true])])
+AC_CHECK_HEADER(sys/acl.h, [], [AM_CONDITIONAL([WITHOUT_XATTR], [true])])
+
AC_ARG_WITH([lzo],
[AS_HELP_STRING([--without-lzo], [Disable support for LZO compression])],