aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRitesh Harjani <riteshh@codeaurora.org>2018-06-06 15:09:00 +0530
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2018-06-14 09:19:10 +0200
commitf1feccec5ad848b4f763376480a006a9d58fa721 (patch)
treefa2d174cfe67d5ea706255afe5a84f78b10da942 /Makefile.am
parent08cc6a2af66e62e3228e17bfa8e8aa918643d06e (diff)
mkfs.ubifs: Implement selinux labelling support in mkfs.ubifs.
This implements/adds selinux labelling support to mkfs.ubifs utility. It adds an extra option in configure to enable selinux labelling support and then finally in mkfs.ubifs adds an extra option to pass the file_contexts which is looked up for filesystem file labels. - Default behavior is kept without selinux so as to not break existing support where selinux library/headers may not be present. - If this is configured with --with-selinux then XATTR from the file_contexts(passed with --selinux option while mkfs.ubifs) will be taken and not from the host file's xattr. This is done to avoid the problem where the host OS may have selinux enabled and hence same xattr names will be present in both host filesystem files and from the --selinux=file passed. So the existing behavior is kept mutually exclusive and preference is given to selinux xattrs (if configured with --with-selinux). Signed-off-by: Ritesh Harjani <riteshh@codeaurora.org> Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a6e77c..391edef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,6 +10,10 @@ if WITHOUT_LZO
AM_CPPFLAGS += -DWITHOUT_LZO
endif
+if WITH_SELINUX
+AM_CPPFLAGS += -DWITH_SELINUX
+endif
+
sbin_PROGRAMS =
sbin_SCRIPTS =
check_PROGRAMS =