aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSascha Hauer <s.hauer@pengutronix.de>2021-02-26 11:24:21 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2021-02-28 13:36:26 +0100
commite91700286ff531f344f4d9a1f1c96c501bfeadad (patch)
tree986bebe7236aa71668eb57900e5438bb7a34aec6 /Makefile.am
parent7170a28d46d5db1e7a9da24a5555a194a233ef0b (diff)
mtd-utils: Use AC_SYS_LARGEFILE
Currently mtd-utils on 32bit systems fail on devices >2GiB due to off_t being a signed 32bit type. Add AC_SYS_LARGEFILE to make off_t a 64bit type. Adding AC_SYS_LARGEFILE results in _FILE_OFFSET_BITS being defined to 64 in include/config.h. To let this have an effect we must make sure that include/config.h is included before all other includes which is archieved by adding its inclusion to CPPFLAGS. Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de> Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d4de62c..9da38af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
ACLOCAL_AMFLAGS = -I m4
-AM_CPPFLAGS = $(WARN_CFLAGS) -D_GNU_SOURCE -std=gnu99 -I$(top_srcdir)/include
+AM_CPPFLAGS = $(WARN_CFLAGS) -D_GNU_SOURCE -std=gnu99 -I$(top_srcdir)/include \
+ -include $(top_builddir)/include/config.h
if WITHOUT_XATTR
AM_CPPFLAGS += -DWITHOUT_XATTR