aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Woodhouse <dwmw2@shinybook.infradead.org>2006-04-11 19:09:16 -0400
committerDavid Woodhouse <dwmw2@shinybook.infradead.org>2006-04-11 19:09:16 -0400
commit72212c137c574b564723327af751c4054c7cfca6 (patch)
tree13be2da9d4be695002d6ea9c396660c986e5fa5c /Makefile.am
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..d9818fb
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,18 @@
+## Process this file with automake to produce Makefile.in
+
+sbin_PROGRAMS = ftl_format erase eraseall nftldump nanddump doc_loadbios \
+ nftl_format mkfs.jffs ftl_check nandtest nandwrite mkfs.jffs2 \
+ lock unlock einfo mtd_debug fcp
+
+CFLAGS = -O2 -Wall
+INCLUDES = -I@CONFIG_KERNELDIR@/include -I@CONFIG_KERNELDIR@/fs/jffs2
+SYMLINKS = crc32.h crc32.c compr_rtime.c compr_rubin.c compr_zlib.c compr.c pushpull.c pushpull.h histo_mips.h compr_rubin.h
+CLEANFILES = $(SYMLINKS)
+
+mkfs_jffs2_SOURCES = mkfs.jffs2.c $(SYMLINKS)
+
+$(SYMLINKS):
+ ln -sf @CONFIG_KERNELDIR@/fs/jffs2/$@ $@
+
+compr.o: compr.c
+ $(COMPILE) $(CFLAGS) $(INCLUDES) -Dprintk=printf -DKERN_NOTICE= -DKERN_WARNING= -c -o $@ $<