aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2020-10-19 12:14:25 +0200
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2021-01-20 12:01:53 +0100
commit7170a28d46d5db1e7a9da24a5555a194a233ef0b (patch)
treead9ef7d83143df6c5597473ef24b6bebbd7a6a63 /Makefile.am
parenta888044525d9f03290cc1afe62dcfa3bec4bc0b9 (diff)
Fix test binary installation
- Remove "install tests" configure option, we already have an option whether to build tests or not. Don't try to work around autotools semantics that people building the package expect. - Fix the installation path by propperly defining it and using the correct name for the libexec path. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ce8fc89..d4de62c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,11 +32,13 @@ check_PROGRAMS =
noinst_LIBRARIES =
noinst_PROGRAMS =
noinst_SCRIPTS =
-pkglibexec_PROGRAMS =
-pkglibexec_SCRIPTS =
dist_man1_MANS =
dist_man8_MANS =
+testdir = @TESTBINDIR@
+test_PROGRAMS =
+test_SCRIPTS =
+
TESTS =
EXTRA_DIST = COPYING