aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2016-12-21 15:42:12 +0100
committerDavid Oberhollenzer <david.oberhollenzer@sigma-star.at>2016-12-22 01:28:20 +0100
commit2d1e23ce1162c15941a213393def72cc06ae457e (patch)
tree2d6ade7908ea00e27f9e89aa350546231ce3d260 /Makefile.am
parent55dd808e71cb7e080a2643e0302321f4a1f699d3 (diff)
mtd-utils: Add configure switches to disable jffsX or ubifs tools
For some applications, like building a root filesystem for an embedded device, it may be desireable to only build and install a subset of the mtd-utils. This can be done throught the targets of the generated Makefile and hand picking executables, however the jffsX and ubifs utilities have external build dependencies that may not be needed. This patch adds configure switches to disable building the jffsX and ubifs utilities. Their respective build dependencies (zlib, lzo, uuid) are only requested if the tools are being built. Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at> Reviewed-by: Richard Weinberger <richard@nod.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 23c1940..31b21bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,11 +36,17 @@ EXTRA_DIST += $(GLOBAL_HEADER) $(GLOBAL_EXTRA)
include lib/Makemodule.am
include ubi-utils/Makemodule.am
-include ubifs-utils/Makemodule.am
include misc-utils/Makemodule.am
include nand-utils/Makemodule.am
include nor-utils/Makemodule.am
+
+if BUILD_UBIFS
+include ubifs-utils/Makemodule.am
+endif
+
+if BUILD_JFFSX
include jffsX-utils/Makemodule.am
+endif
if BUILD_TESTS
include tests/ubi-tests/Makemodule.am